Printix connection issues

Minor incident Infrastructure
2024-09-09 14:52 BST · 48 minutes

Updates

Resolved

Printix have announced that this issue is now resolved. If you continue to have problems logging in to Printix, please restart and try again.

September 9, 2024 · 15:40 BST
Issue

Printix are currently reporting connection issues for some users. They are investigating the cause. We will update this page when we have further information.

September 9, 2024 · 14:52 BST

← Back