Microsoft 365 Incident

Major incident Infrastructure
2025-10-29 16:24 GMT · 17 hours, 24 minutes

Updates

Resolved

All Microsoft 365 services are now operating as normal. The earlier issues affecting access and performance have been resolved.

If you continue to experience issues with anything, please get in touch with help@kindleworthtech.com.

October 30, 2025 · 09:49 GMT
Investigating

All Microsoft 365 services are now operating as normal. The earlier issues affecting access and performance have been resolved.

If you continue to experience issues with anything, please get in touch with help@kindleworthtech.com.

October 30, 2025 · 09:49 GMT
Monitoring

Core Microsoft 365 services now appear to be largely functioning as expected. Users should be able to access primary applications such as Outlook, Teams, OneDrive, and SharePoint.

However, you may still experience intermittent issues or delayed updates across some M365 services as Microsoft continues to fully stabilise the platform.

We will continue to monitor the situation and provide updates as new information becomes available. Thank you for your patience, and if you have any questions, please email us at help@kindleworthtech.com.

October 29, 2025 · 17:30 GMT
Issue

We are currently experiencing a service disruption affecting some Microsoft 365 products.

You may be unable to access or use core M365 applications such as Outlook, Teams, and OneDrive.

Our team is investigating the issue and monitoring Microsoft’s service health communications for updates. We hope to provide an update within the next hour.

October 29, 2025 · 16:24 GMT

← Back